Chapter 7
RIP version 2
Routing Protocols and Concepts
2
Topics
RIPv1 Limitations
RIPv1: Topology Limitations
RIPv1: Discontiguous
Networks
RIPv1: No VLSM Support
RIPv1: No CIDR Support
Configuring RIPv2
Enabling and Verifying RIPv2
Auto-Summary and RIPv2
Disabling Auto-Summary in
RIPv2
Verifying RIPv2 Updates
VLSM and CIDR
RIPv2 and VLSM
RIPv2 and CIDR
Verifying and Troubleshooting
RIPv2
Verification and
Troubleshooting Commands
Common RIPv2 Issues
Authentication
RIPv1 Limitations
RIPv1: Topology Limitations
RIPv1: Discontiguous Networks
RIPv1: No VLSM Support
RIPv1: No CIDR Support
4
Note on Classful Routing Protocols, RIPv1 limitations
The first part of this presentation discusses the limitations of classful
routing protocols such as RIPv1.
RIPv1 is used as an example, so we can see how RIPv2 a classless
routing protocol does not have these same limitations.
Classful routing protocols have three major limitations:
Does not support discontiguous networks.
Does not support VLSM
Does not support CIDR
Instead of just “memorizing” these facts, we will demonstrate and
“understand” why a classful routing protocol has these limitations.
5
RIPv1: Distance Vector, Classess Routing Protocol
RIP Version 2 (RIPv2) is defined in RFC 1723.
RIPv2 is the first classless routing protocol discussed in this book.
RIPv2 has lost popularity when compared to other routing protocols
such as EIGRP, OSPF and IS-IS.
RIPv2, it is ideal for explaining the differences between a classful
routing protocol (RIPv1) and a classless routing protocol (RIPv2).
6
RIPv1 and RIPv2
RIPv2 is actually an enhancement of RIPv1’s features and extensions
rather than an entirely new protocol.
Next-hop addresses included in the routing updates
Use of multicast addresses in sending updates
Authentication option available
Both versions of RIP share the following features and limitations:
Use of hold-down and other timers to help prevent routing loops
Use of split horizon and split horizon with poison reverse to also
help prevent routing loops
Use of triggered updates when there is a change in the topology for
faster convergence
Maximum hop count of 15 hops, with the hop count of 16 signifying
an unreachable network
7
In a discontiguous network, a classful major network address, such as
172.30.0.0/16, is separated by one or more other major networks.
172.30.0.0/16 is divided by the networks:
209.165.200.228/30
209.165.200.232/30
Classful routing protocols do not include enough routing information to
route properly for discontiguous networks.
RIPv1 Limitations
172.30.0.0
/16
172.30.0.0
/16
8
R2: static summary route to the 192.168.0.0/16 network.
Redistribution - Inject static route(s) into routing protocol updates.
For now, this summary route will cause problems with RIPv1 because:
192.168.0.0/16 is not a major classful address (192.168.0.0/24)
Includes all the /24 versions of 192.168.0.0/16
Summary Route
172.30.0.0/16
172.30.0.0
/16
R2(config)# ip route 192.168.0.0 255.255.0.0 null0
9
R1 and R3 contain VLSM networks.
Both R1 and R3 are configured with /24 subnets of the 172.30.0.0/16
network.
R3: 172.30.200.0/24 subnetted again, using the first 4 bits for subnets and
the last 4 for hosts.
172.30.200.16/28 and 172.30.200.32/28
VLSM
172.30.0.0/16
172.30.0.0
/16
10
VLSM
R3: 172.30.200.0/24 subnetted again, using the first 4 bits for
subnets and the last 4 for hosts.
172.30.200.16/28 and 172.30.200.32/28
11
We use RFC 1918 and Cisco Example addresses for all topologies.
Private Addresses and Cisco Example Addresses
RFC 1918 Private Addresses
Cisco Example Addresses
12
Loopback interface
Software-only interface
Used to emulate an interface.
Can be assigned an IP address.
Specific purposes with some routing protocols such as OSPF (later)
A loopback interface can be:
pinged
subnet advertised in routing updates.
Ideal for simulating multiple networks attached to the same router.
Loopback Interfaces
172.30.0.0/16
172.30.0.0
/16
13
RIPv1 Topology Limitations
RIPv1 configuration for all three routers
R1(config)# router rip
R1(config-router)# network 172.30.0.0
R1(config-router)# network 209.165.200.0
R2(config)# ip route 192.168.0.0 255.255.0.0 null0
R2(config)# router rip
R2(config-router)# redistribute static
R2(config-router)# network 10.0.0.0
R2(config-router)# network 209.165.200.0
R3(config)# router rip
R3(config-router)# network 172.30.0.0
R3(config-router)# network 209.165.200.0
14
Static Routes and
Null Interfaces
CIDR allows route aggregation.
A single high-level route entry with a subnet mask less than the classful
mask can be used to represent many lowerlevel routes.
This results in fewer entries in the routing table.
The static route on R2 is using a /16 mask to summarize all 256 networks
ranging from 192.168.0.0/24 to 192.168.255.0/24.
For Lab purposes:
The static summary route 192.168.0.0/16 does not actually exist.
To simulate this static route, we will use a null interface as the exit
interface.
You do not need to enter commands to create or configure the null
interface.
It is always up but does not forward or receive traffic.
Traffic sent to the null interface is discarded.
R2(config)# ip route 192.168.0.0 255.255.0.0 Null0
15
Route Redistribution
Redistribution involves taking the routes from one routing source and
sending those routes to another routing source.
Routes can only be redistributed into a dynamic routing protocol.
Dynamic routing protocol to a different dynamic routing protocol.
Static routes to a dynamic routing protocol.
Directly connected networks to a dynamic routing protocol.
Want R2 to redistribute our static route (192.168.0.0/16) by importing the
route into RIPv1 and then sending it to R1 and R3 using the RIPv1 process.
We will see whether this is indeed happening, and if not, why not.
R2(config)# ip route 192.168.0.0
255.255.0.0 null0
R2(config)# router rip
R2(config-router)# redistribute static
Is static route being sent via RIPv1 with other RIPv1 routes?
16
Verifying and Testing
Connectivity
Whenever R2 pings any of the 172.30.0.0 subnets on R1 or R3, only
about 50 percent of the pings are successful.
R2# ping 172.30.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.1.1, timeout is 2 seconds:
!U!.!
Success rate is 60 percent (3/5), round-trip min/avg/max = 28/29/32 ms
R2# ping 172.30.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.100.1, timeout is 2 seconds:
!U!.!
Success rate is 60 percent (3/5), round-trip min/avg/max = 28/28/28 ms
R2#
17
Verifying and Testing
Connectivity
R1 is able to ping 10.1.0.1 but is unsuccessful when attempting to
ping the 172.30.100.1 interface on R3.
R1# ping 10.1.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5),round-trip min/avg/max = 28/28/28 ms
R1# ping 172.30.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.100.1, timeout is 2 seconds:
Success rate is 0 percent (0/5)
R1#
X
18
Verifying and Testing
Connectivity
R3 is able to ping 10.1.0.1 but is unsuccessful when attempting to
ping the 172.30.1.1 interface on R1.
As you can see, there is an obvious problem when trying to
communicate with the 172.30.0.0 discontiguous subnets.
R3# ping 10.1.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5),round-trip min/avg/max = 28/28/28 ms
R3# ping 172.30.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.1.1, timeout is 2 seconds:
Success rate is 0 percent (0/5)
R3#
X
19
RIPv1: Discontiguous Networks
Because the subnet mask is not included in the update, RIPv1 and
other classful routing protocols must summarize networks at major
network boundaries.
20
RIPv1 on both Routers R1 and R3 will summarize their 172.30.0.0
subnets to the classful major network address of 172.30.0.0 when
sending routing updates to R2.
RIPv1:
Discontiguous
Networks
21
Examining the Routing Tables
R2 has two equal-cost routes to the 172.30.0.0/16 network.
R1 and R3 are sending R2 a RIPv1 update for the 172.30.0.0 network
with a metric of 1 hop.
R2’s routing table only contains the major classful network address of
172.30.0.0 and adds the Class B subnet mask of /16.
R2# show ip route
R 172.30.0.0/16 [120/1] via 209.165.200.230, 00:00:09, Serial0/0/0
[120/1] via 209.165.200.234, 00:00:11, Serial0/0/1
209.165.200.0/30 is subnetted, 2 subnets
C 209.165.200.232 is directly connected, Serial0/0/1
C 209.165.200.228 is directly connected, Serial0/0/0
10.0.0.0/16 is subnetted, 1 subnets
C 10.1.0.0 is directly connected, FastEthernet0/0
S 192.168.0.0/16 is directly connected, Null0
22
debug ip rip
R2 is receiving two 172.30.0.0 equal-cost routes with a metric of 1 hop:
one route on Serial 0/0/0 from R1 and
the other route on Serial 0/0/1 from R3.
Also notice that the subnet mask is not included with the network
address in the update.
R2# debug ip rip
RIP: received v1 update from 209.165.200.230 on Serial0/0/0
172.30.0.0 in 1 hops
RIP: received v1 update from 209.165.200.234 on Serial0/0/1
172.30.0.0 in 1 hops
RIP: sending v1 update to 255.255.255.255 via Serial0/0/0
(209.165.200.229)
RIP: build update entries
network 10.0.0.0 metric 1
subnet 209.165.200.232 metric 1
RIP: sending v1 update to 255.255.255.255 via Serial0/0/1
(209.165.200.233)
RIP: build update entries
network 10.0.0.0 metric 1
subnet 209.165.200.228 metric 1
23
show ip route
R1 has its own 172.30.0.0 routes:
172.30.2.0/24
172.30.1.0/24.
R1 does not send R2 those subnets.
R1 and R3 are boundary routers only sending the summarized 172.30.0.0
Result, R2 only knows about the 172.30.0.0/16 classful network and is
unaware of any 172.30.0.0 subnets.
R1# show ip route
172.30.0.0/24 is subnetted, 2 subnets
C 172.30.2.0 is directly connected, Loopback0
C 172.30.1.0 is directly connected, FastEthernet0/0
209.165.200.0/30 is subnetted, 2 subnets
R 209.165.200.232 [120/1] via 209.165.200.229, 00:00:16,Serial0/0/0
C 209.165.200.228 is directly connected, Serial0/0/0
R 10.0.0.0/8 [120/1] via 209.165.200.229, 00:00:16, Serial0/0/0
R1#
24
Determining the mask and network address
Receiving an Update: Determining subnet mask for routing table
What is the major classful network address of the receiving interface?
What is the major classful network address of the network in the routing
update?
Are they the same major classful network address?
Yes: Apply subnet mask of the receiving interface for this network
address in the routing table.
No: Apply classful subnet mask for this network address in the
routing table.
Sending an Update: Determining whether or not to summarize route sent
What is the major classful network address of the sending interface?
What is the major classful network address of the network in the routing
update?
Are they the same major classful network address?
Yes: Send subnet network address
No: Send summary address – the classful network address
25
Example 1
172.16.0.0/1610.0.0.0/8 192.168.1.0/24
.1 .1 .1.2