Linux CentOS
Unix Solaris
Kiến trúc HĐH Linux
Kernel trợ giúp HĐH quản lý
Thiết bị (Devices)
Bộ nhớ (Memory)
Các tiến trình (Processes)
Liên lạc (Communication)
Quản lý phần cứng
Bao gồm các thao tác tập tin,
nén, sao lưu tập tin, các trình
biên dịch, gỡ lỗi, soạn văn bản
Đặc điểm chính
Filesystem
KN
Là cách tổ chức dữ liệu trên thiết bị lưu trữ dữ liệu. Linux hỗ trợ nhiều
filesystem khác nhau để giao tiếp với những HĐH khác như: ext2, ext3,
iso9660, vfat …
Các lệnh lấy thông tin của filesystem
◦
Lệnh df tổng kết việc sử dụng vùng đĩa trống trên đĩa
◦
Lệnh du ước lượng khối lượng vùng đĩa trống
Mount filesystem
◦
Nghĩa là gắn kết các block device vào một điểm mount. Điểm mount phải
là một thư mục rỗng trên cây thư mục
◦
Cú pháp câu lệnh:
#mount –t [loại_filesystem] [tên_thiết_bị] [điểm_mount]
Cây thư mục
/bin: chứa các chương trình thực thi và tập tin hệ thống
/boot: chứa image và những tập tin khởi động hệ điều hành
/dev: lưu các tập tin thiết bị
/etc: lưu các tập tin cấu hình của hệ thống cũng như của các dịch vụ
/etc/rc.d/init.d: lưu các script khởi động của hệ thống
và dịch vụ
/home: lưu các thư mục cá nhân của người dùng trong
hệ thống
/lost+found: lưu các dữ liệu không gắn với thư mục
nào khi khởi động hệ thống hay khi chạy chương trình
fsck
/lib: lưu các hàm thư viện
/mnt: có 2 thư mục con là floopy và cd-rom để
mount tạm thời các thiết bị như đĩa mềm, CD-
ROM
/sbin: lưu các chương trình dành cho người
quản trị
/var: lưu những log của hệ thống và các
dịch vụ, hàng đợi của các dịch vụ như
máy in, mail…
/usr: lưu và chứa các tập tin của các ứng
dụng đã được cài đặt cho người dùng
Các lệnh cơ bản
Các lệnh quản lý hệ thống
Các lệnh phân quyền
Các lệnh xử lý tiến trình
Các lệnh thao tác với tập tin
Các lệnh liên quan tới mạng
Các lệnh cơ bản khác
chmod
chown
chgrp
ls –l
xem chi tiết
top
ps
pstree
kill
pkill, killall
sleep
renice
ifconfig
route
more /etc/resolv.conf
gedit /etc/resolv.conf
ping
service network restart
exit
logout
reboot
shutdown
Kiến trúc tổng quát giống Linux (Kernel,
Shell)
Về tập lệnh
Cơ bản giống với Linux
Tài liệu
“UNIX® Essentials Featuring the Solaris™ 10 Operating
System SA-100-S10, Student Guide”, Sun Microsystems, 2005
Sự khác biệt về tập lệnh
CentOS Solaris
shutdown
shutdown -h now (or) poweroff shutdown -y -g0 -i5 (or) init 5
reboot reboot (or) shutdown -y -g0 -i6 (or) init 6
kernel
/sbin/lsmod modinfo
/sbin/insmod modload
/sbin/rmmod modunload
scanpci /usr/x11/bin/scanpci (or) prtconf -v
printing
lp (or) lpr lp (or /usr/ucb/lpr)
lpstat (or) lpq lpstat (or /usr/ucb/lpq)
services
/sbin/service status-all svcs –a
/sbin/service sendmail stop svcadm disable sendmail
/sbin/service sendmail start svcadm enable sendmail
/sbin/service sendmail status svcs sendmail
/sbin/chkconfig –list svcs –a
/sbin/chkconfig –add /etc/rc3.d/f00 svccfg import f00.xml
/sbin/chkconfig sendmail on svcadm enable sendmail
Sự khác biệt về tập lệnh
CentOS Solaris
monitoring
top prstat
cat /proc/cpuinfo psrinfo –v
cat /proc/meminfo prtconf
nfs
exportfs exportfs (or) share
(edit /etc/exports) share /home (or) zfs sharenfs=on
networking
/sbin/mii-tool ndd (or) /sbin/dladm show-dev
ifconfig ifconfig -a
/sbin/ethtool ndd
/sbin/dhclient dhcpagent
iptables ipfilter
Sự khác biệt về tập lệnh
CentOS Solaris
storage
fdisk fdisk (and) format
parted format
mkfs -t ext3 /dev/hda1 mkfs -f ufs /dev/rdsk/c0t0d0s0 (or) newfs
/dev/rdsk/c0t0d0s0
cdrecord dev=2,0 f00.iso cdrw -i f00.iso
tar xfvj f00.tar.bz2 gtar xfvj f00.tar.bz2
lvm/pv*/lv*/vg* meta*
dev
(edit /etc/ld.so.conf) crle
gcc /opt/csw/bin/gcc
ld /usr/ccs/bin/ld
Thực hành
Viewing directories and files
Changing the Solaris OS directory contents
Using command within the Shell
Using basic file permissions
Configuring access control lists (ACLs)
Mail
◦
Hoạt động, các dịch vụ mail
DNS
◦
Cơ chế phân giải tên miền
AntiSpam
◦
Các kỹ thuật chống spam
AntiRelay
LDAP
◦
Giao thức truy cập nhanh các dịch vụ thư mục
Thực hành với Solaris
◦
Searching files and directories
◦
Performing basic process control
◦
Advanced Shell scripts
◦
Creating archives
◦
Compressing, viewing, and uncompressing files