Tải bản đầy đủ (.doc) (4 trang)

Easy VPN kết hợp site-to-site VPN docx

Bạn đang xem bản rút gọn của tài liệu. Xem và tải ngay bản đầy đủ của tài liệu tại đây (142.82 KB, 4 trang )

Mục đích bài lab:
Hướng dẫn cấu hình hoàn chỉnh: ADSL, BRAS, VPN server(router), VPN client.
Ở đây sẽ kết hợp cả VPN site-to-site và VPN client-to-site (easy VPN)
Cấu hình ADSL (client 1 và client 2, ở đây do không có modem nên ta giả định router
làm ADSL client 2)
ADSL1
Code:
ADSL1#sh run
hostname ADSL1
!
!
ip dhcp pool pool172
import all
network 172.16.1.0 255.255.255.0
default-router 172.16.1.254
!
interface ATM0/0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
pvc 8/35
pppoe-client dial-pool-number 1
!
!
interface Ethernet0/0
ip address 172.16.1.254 255.255.255.0
ip nat inside
half-duplex
!
interface Dialer1
ip address negotiated


ip nat outside
encapsulation ppp
dialer pool 1
!
ip nat inside source list 1 interface Dialer1 overload
ip http server
no ip http secure-server
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
access-list 1 permit 172.16.1.0 0.0.0.255
!
ADSL1#sh ip route
100.0.0.0/32 is subnetted, 2 subnets
C 100.0.0.6 is directly connected, Dialer1
C 100.0.0.1 is directly connected, Dialer1
172.16.0.0/24 is subnetted, 1 subnets
C 172.16.1.0 is directly connected, Ethernet0/0
S* 0.0.0.0/0 is directly connected, Dialer1
ADSL1#sh ip int br
Interface IP-Address OK? Method Status
Protocol
ATM0/0 unassigned YES NVRAM up
up
Ethernet0/0 172.16.1.254 YES NVRAM up
up
Virtual-Access1 unassigned YES unset up
up
Dialer1 100.0.0.6 YES IPCP up

up
ADSL 2
Code:
ADSL2#sh run
hostname ADSL2
ip dhcp pool client
import all
network 10.0.0.0 255.255.255.0
dns-server 10.0.0.254
default-router 10.0.0.254
!
interface ATM0/0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
pvc 8/35
pppoe-client dial-pool-number 1
!
interface FastEthernet0/0
ip address 10.0.0.254 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface Dialer1
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
!

ip nat inside source list 1 interface Dialer1 overload
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
access-list 1 permit 10.0.0.0 0.0.0.255
!
ADSL2#sh ip route
100.0.0.0/32 is subnetted, 2 subnets
C 100.0.0.1 is directly connected, Dialer1
C 100.0.0.3 is directly connected, Dialer1
10.0.0.0/24 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 is directly connected, Dialer1
ADSL2#sh ip int br
Interface IP-Address OK? Method Status
Protocol
ATM0/0 unassigned YES NVRAM up
up
FastEthernet0/0 10.0.0.254 YES NVRAM up
up
Virtual-Access1 unassigned YES unset up
up
Dialer1 100.0.0.3 YES IPCP up
up

×