Tải bản đầy đủ (.pdf) (1 trang)

Tài liệu IP Routing and NAT doc

Bạn đang xem bản rút gọn của tài liệu. Xem và tải ngay bản đầy đủ của tài liệu tại đây (74.05 KB, 1 trang )

IP ROUTING PROCESS

Key Commands Shows and Debugs

No ip route-cache (will show all packets in debug)

Policy Routing:

Access-list 1 permit 10.0.0.0 0.255.255.255
Route-map blah permit 10
Match ip address 1
Set default interface serial 0
Route-map blah permit 10
!
interface ethernet 0
ip address 20.1.1.1 255.255.255.0
ip policy route-map blah
Show ip cache
Debug ip routing
Debug ip packet

Show ip route 172.0.0.0 255.0.0.0 longer-prefix
Additional Commands

NAT:
Ip nat pool ccie 10.1.1.1 10.1.1.254 netmask
255.255.255.0
ip nat inside source list 1 pool ccie
interface ethernet 0
ip nat inside
ip address 20.1.1.1 255.255.255.0


interface serial 0
ip nat outside
!
access-list 1 permit 20.1.1.0 0.0.0.255
!
Or,
Ip nat inside source list 1 interface s 0 overload
Or
Ip nat inside source list 1 pool ccie rotary

Show ip nat translation
Show ip nat statistics
Clear ip nat trans *
Debug ip nat

Spot The Issue Notes
In debug ip packet, if seeing "encapsulation
failed" on frame, check frame map. If
encapsulation failed on ethernet, no arp reply,
so can't encaps into layer 3.

Remember that loopback interfaces will show up as
/32 routes in OSPF and EIGRP. Configure a
summary address or range in order to reflect the
proper subnet carried by the loopback interface.
This is most important in LAT translation and NAT
when a NAT address or LAT translation address
calls for an address within the loopback's
subnet. The remote router won't know about that
address since only the /32 address of the

loopback interface itself will be advertised.
Same for PPP dialup routes apparently.


×