Tải bản đầy đủ (.pdf) (11 trang)

Tài liệu Routing Principles and IOS Implementation Lab Scenario doc

Bạn đang xem bản rút gọn của tài liệu. Xem và tải ngay bản đầy đủ của tài liệu tại đây (43.84 KB, 11 trang )

CertificationZone Page 1 of 11
/?Issue=3&IssueDate=11-01-1999&CP= 11/06/01
Date of Issue: 11-01-1999
Routing Principles and IOS
Implementation
Lab Scenario
by Howard C. Berkowitz
Objective
A Reality Check
Router Configurations
PARSLEY's Configuration:
THYME's Configuration:
SAGE's Configuration:
ROSEMARY's Configuration:
First Pass
Router Configurations
PARSLEY's Configuration:
THYME's Configuration:
SAGE's Configuration:
ROSEMARY's Configuration:
Analysis
TIP
The Distance command
Objective
The existing configuration runs IGRP. Convert the network to run OSPF without using redistribution. Run OSPF and
IGRP in parallel at first, continuing the use of IGRP as the active routing protocol, until you verify OSPF operation.
Figure 1 shows the initial physical configuration and addressing of the routers.
Figure 1
A Reality Check
Can you ping and traceroute to all interfaces, including the loopbacks? Why? Why not?
CertificationZone Page 2 of 11


/?Issue=3&IssueDate=11-01-1999&CP= 11/06/01
Router Configurations
These configurations work with IGRP.
PARSLEY's Configuration:
parsley#s ru
Building configuration
Current configuration:
!
version 11.0
service udp-small-servers
service tcp-small-servers
!
hostname parsley
!
enable password pass
!
ip subnet-zero
!
interface Loopback0
ip address 192.168.254.254 255.255.255.0
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
!
interface Ethernet1
no ip address
shutdown
!
interface Serial0
ip address 192.168.3.1 255.255.255.252

no fair-queue
!
interface Serial1
no ip address
shutdown
!
interface TokenRing1
no ip address
shutdown
!
interface TokenRing0
ip address 192.168.2.1 255.255.255.0
ring-speed 16
!
router igrp 1
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
!
ip host thyme 192.168.1.2
ip host sage 192.168.1.3
ip host rosemary 192.168.1.4
!
!
line con 0
exec-timeout 0 0
line aux 0
transport input all
line vty 0 4
no login

!
end
parsley#
THYME's Configuration:
CertificationZone Page 3 of 11
/?Issue=3&IssueDate=11-01-1999&CP= 11/06/01
thyme#s ru
Building configuration
Current configuration:
!
version 11.0
service udp-small-servers
service tcp-small-servers
!
hostname thyme
!
enable password pass
!
ip subnet-zero
!
interface Loopback0
ip address 192.168.253.253 255.255.255.0
!
interface Ethernet0
ip address 192.168.1.2 255.255.255.0
!
interface Ethernet1
no ip address
shutdown
!

interface Ethernet2
no ip address
shutdown
!
interface Ethernet3
no ip address
shutdown
!
interface Serial0
ip address 192.168.3.2 255.255.255.252
no fair-queue
!
interface Serial1
ip address 192.168.3.5 255.255.255.252
!
interface Serial2
no ip address
shutdown
!
interface Serial3
no ip address
shutdown
!
interface TokenRing1
no ip address
shutdown
!
interface TokenRing0
ip address 192.168.2.2 255.255.255.0
ring-speed 16

!
router igrp 1
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
!
ip host parsley 192.168.1.1
ip host sage 192.168.1.3
ip host rosemary 192.168.1.4
!
!
line con 0
line aux 0
transport input all
line vty 0 4
no login
!
end
thyme#
CertificationZone Page 4 of 11
/?Issue=3&IssueDate=11-01-1999&CP= 11/06/01
SAGE's Configuration:
sage#s ru
Building configuration
Current configuration:
!
version 11.0
service udp-small-servers
service tcp-small-servers
!

hostname sage
!
enable password pass
!
!
interface Loopback0
ip address 192.168.252.252 255.255.255.0
!
interface Ethernet0
ip address 192.168.1.3 255.255.255.0
!
interface Ethernet1
no ip address
shutdown
!
interface Serial0
ip address 192.168.3.6 255.255.255.252
no fair-queue
!
interface Serial1
no ip address
shutdown
!
interface TokenRing1
no ip address
shutdown
!
interface TokenRing0
ip address 192.168.2.3 255.255.255.0
ring-speed 16

!
router igrp 1
network 192.168.1.0
network 192.168.2.0
!
ip host parsley 192.168.1.1
ip host thyme 192.168.1.2
ip host rosemary 192.168.1.4
!
!
line con 0
line aux 0
transport input all
line vty 0 4
no login
!
end
sage#
ROSEMARY's Configuration:
rosemary#s ru
Building configuration
Current configuration:
!
version 11.0
service udp-small-servers
service tcp-small-servers
!
hostname rosemary
CertificationZone Page 5 of 11
/?Issue=3&IssueDate=11-01-1999&CP= 11/06/01

!
enable password pass
!
!
interface Loopback0
ip address 192.168.251.251 255.255.255.0
!
interface Ethernet0
ip address 192.168.1.4 255.255.255.0
!
interface Ethernet1
no ip address
shutdown
!
interface Serial0
no ip address
shutdown
no fair-queue
!
interface Serial1
no ip address
shutdown
!
interface TokenRing1
no ip address
shutdown
!
interface TokenRing0
ip address 192.168.2.4 255.255.255.0
ring-speed 16

!
router igrp 1
network 192.168.1.0
network 192.168.2.0
!
ip host parsley 192.168.1.1
ip host thyme 192.168.1.2
ip host sage 192.168.1.3
!
!
line con 0
exec-timeout 0 0
line aux 0
transport input all
line vty 0 4
no login
!
end
First Pass
Here's a first attempt at the solution, improved by adding a more efficient addressing structure. Does it meet the
requirements of the scenario? (see "First Pass Analysis" below.)
Router Configurations
PARSLEY's Configuration:
parsley#s ru
Building configuration
Current configuration:
!
version 11.0
service udp-small-servers
service tcp-small-servers

!
hostname parsley
!
CertificationZone Page 6 of 11
/?Issue=3&IssueDate=11-01-1999&CP= 11/06/01
enable password pass
!
ip subnet-zero
!
interface Loopback0
ip address 192.168.254.254 255.255.255.0
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
!
interface Ethernet1
no ip address
shutdown
!
interface Serial0
ip address 192.168.3.1 255.255.255.252
no fair-queue
!
interface Serial1
no ip address
shutdown
!
interface TokenRing1
no ip address
shutdown

!
interface TokenRing0
ip address 192.168.2.1 255.255.255.0
ring-speed 16
!
router ospf 1
network 192.168.1.1 0.0.0.0 area 0.0.0.1
network 192.168.2.1 0.0.0.0 area 0.0.0.1
network 192.168.3.1 0.0.0.0 area 0.0.0.1
network 192.168.254.254 0.0.0.0 area 0.0.0.1
!
router igrp 1
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
!
ip host thyme 192.168.1.2
ip host sage 192.168.1.3
ip host rosemary 192.168.1.4
!
!
line con 0
exec-timeout 0 0
line aux 0
transport input all
line vty 0 4
no login
!
end
parsley#

THYME's Configuration:
thyme#s ru
Building configuration
Current configuration:
!
version 11.0
service udp-small-servers
service tcp-small-servers
!
hostname thyme
!
enable password pass
!
ip subnet-zero
!
interface Loopback0
CertificationZone Page 7 of 11
/?Issue=3&IssueDate=11-01-1999&CP= 11/06/01
ip address 192.168.253.253 255.255.255.0
!
interface Ethernet0
ip address 192.168.1.2 255.255.255.0
!
interface Ethernet1
no ip address
shutdown
!
interface Ethernet2
no ip address
shutdown

!
interface Ethernet3
no ip address
shutdown
!
interface Serial0
ip address 192.168.3.2 255.255.255.252
no fair-queue
!
interface Serial1
ip address 192.168.3.5 255.255.255.252
!
interface Serial2
no ip address
shutdown
!
interface Serial3
no ip address
shutdown
!
interface TokenRing1
no ip address
shutdown
!
interface TokenRing0
ip address 192.168.2.2 255.255.255.0
ring-speed 16
!
router ospf 1
network 192.168.1.2 0.0.0.0 area 0.0.0.1

network 192.168.2.2 0.0.0.0 area 0.0.0.1
network 192.168.3.2 0.0.0.0 area 0.0.0.1
network 192.168.3.5 0.0.0.0 area 0.0.0.1
network 192.168.253.253 0.0.0.0 area 0.0.0.1
!
router igrp 1
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
!
ip host parsley 192.168.1.1
ip host sage 192.168.1.3
ip host rosemary 192.168.1.4
!
!
line con 0
line aux 0
transport input all
line vty 0 4
no login
!
end
thyme#
SAGE's Configuration:
sage#s ru
Building configuration
Current configuration:
!
version 11.0
CertificationZone Page 8 of 11

/?Issue=3&IssueDate=11-01-1999&CP= 11/06/01
service udp-small-servers
service tcp-small-servers
!
hostname sage
!
enable password pass
!
!
interface Loopback0
ip address 192.168.252.252 255.255.255.0
!
interface Ethernet0
ip address 192.168.1.3 255.255.255.0
!
interface Ethernet1
no ip address
shutdown
!
interface Serial0
ip address 192.168.3.6 255.255.255.252
no fair-queue
!
interface Serial1
no ip address
shutdown
!
interface TokenRing1
no ip address
shutdown

!
interface TokenRing0
ip address 192.168.2.3 255.255.255.0
ring-speed 16
!
router ospf 1
network 192.168.1.3 0.0.0.0 area 0.0.0.1
network 192.168.2.3 0.0.0.0 area 0.0.0.1
network 192.168.3.6 0.0.0.0 area 0.0.0.1
network 192.168.252.252 0.0.0.0 area 0.0.0.1
!
router igrp 1
network 192.168.1.0
network 192.168.2.0
!
ip host parsley 192.168.1.1
ip host thyme 192.168.1.2
ip host rosemary 192.168.1.4
!
!
line con 0
line aux 0
transport input all
line vty 0 4
no login
!
end
sage#
ROSEMARY's Configuration:
rosemary#s ru

Building configuration
Current configuration:
!
version 11.0
service udp-small-servers
service tcp-small-servers
!
hostname rosemary
!
enable password pass
!
!
CertificationZone Page 9 of 11
/?Issue=3&IssueDate=11-01-1999&CP= 11/06/01
interface Loopback0
ip address 192.168.251.251 255.255.255.0
!
interface Ethernet0
ip address 192.168.1.4 255.255.255.0
!
interface Ethernet1
no ip address
shutdown
!
interface Serial0
no ip address
shutdown
no fair-queue
!
interface Serial1

no ip address
shutdown
!
interface TokenRing1
no ip address
shutdown
!
interface TokenRing0
ip address 192.168.2.4 255.255.255.0
ring-speed 16
!
router ospf 1
network 192.168.1.4 0.0.0.0 area 0.0.0.1
network 192.168.2.4 0.0.0.0 area 0.0.0.1
network 192.168.251.251 0.0.0.0 area 0.0.0.1
!
router igrp 1
network 192.168.1.0
network 192.168.2.0
!
ip host parsley 192.168.1.1
ip host thyme 192.168.1.2
ip host sage 192.168.1.3
!
!
line con 0
exec-timeout 0 0
line aux 0
transport input all
line vty 0 4

no login
!
end
Analysis
These configurations do not meet the requirements. You have a mixture of IGRP and OSPF routes in the active
routing table, which was not the goal. The goal was to keep IGRP running, verify OSPF was collecting the proper
topology, and only then convert to OSPF.
What is wrong?
This space left blank so that you don't peek at the
answer! ;-)
CertificationZone Page 10 of 11
/?Issue=3&IssueDate=11-01-1999&CP= 11/06/01
The reconfiguration was too ambitious. It attempted simultaneously to introduce a new routing protocol and a new
addressing scheme.
See the Tutorial "Routing Principles and IOS Implementation Considerations" for a discussion of how routes are
chosen for routing table installation. The person writing this first configuration forgot that prefix length the number of
one bits in the subnet mask is considered before administrative distance.
While he correctly observed that OSPF's administrative distance is higher (i.e., less preferred) than IGRP's, he forgot
that the VLSM subnets introduced into the network were more specific, and thus preferable, to any IGRP route.
The proper approach to this problem is to change one thing at a
time:
• Add the OSPF routing protocol
• Verify operation
• Add distance commands to make OSPF the preferred protocol
over IGRP
• Change the addressing to VLSM
• Add summarization, stubby areas, and other OSPF
enhancements (not a requirement for this specific scenario)
The Distance command
Cisco uses administrative distance to decide which source is "most

believable" about a route to a certain destination. Administrative
distance breaks ties between routes of the same specificity the
same prefix length (i.e., number of one bits in the subnet mask)
to a given destination.
In the accompanying Tutorial, you will see the default
administrative distance that the IOS assigns to each source of
routing information. You can override these defaults with the
distance subcommand, which you code underneath a router
major command.
TIP
When upgrading both the dynamic routing
protocol and the addressing, upgrade the
routing protocol first, verify operation, and only
then renumber. Keep the network stable during
conversion, changing one thing at a time.
The Bay RS operating system, which is the
equivalent of IOS for Nortel routers and is also
the base of Microsoft RRAS, contains a default
for OSPF routes that differs from Cisco's but
can be quite useful.
Since Bay does not support proprietary IGRP,
they assumed that any conversions would be
from RIP to OSPF. In Bay RS, the OSPF
interface costs defaults to 1, rather than the
108/bandwidth used by most vendors,
including Cisco.
By setting the default to 1, the sum of costs
along any path becomes the hop count. At
least inside areas, OSPF will select the same
paths as would RIP, which simplifies

verification that the new protocol is working in
the same way as the old.
True, summarization at area boundaries, and
CertificationZone Page 11 of 11
/?Issue=3&IssueDate=11-01-1999&CP= 11/06/01
The simplest form of distance changes the administrative distance
of all routing information received from a given source:
Router rip
Redistribute igrp 1
Distance 130
The lines above will assign an administrative distance of 130 to all
IGRP routes learned by RIP. RIP's default administrative distance
is 120. By overriding the administrative distance, you make the
routes redistributed into RIP less desirable than those routes originated in RIP.
Does this form of the distance command fit our scenario, which specifies that you should not use redistribution?
Router igrp 1
Network 172.17.0.0
Distance 120 172.17.1.1 0.0.0.0 1
Access-list 1 permit 172.16.0.0 0.0.255.255
The second form, shown above, is more appropriate for this scenario. In the example, IGRP sets the distance to 120
for all routes received from the advertising router (172.16.2.1) that match access-list 1.
In the distance command, the address and wildcard mask in the distance statement refer to the address of the
advertising router, not the route itself. When using the distance statement with OSPF, the address and wildcard mask
will refer to the router id of the originating router. For this reason, you should use 0.0.0.0 255.255.255.255 to specify
any router speaking OSPF.
So, to make OSPF routes learned to be less preferred to those learned from IGRP, you would code:
Router ospf 1
Network 172.17.0.0
Distance 120 0.0.0.0 255.255.255.255 1
Access-list 1 permit 0.0.0.0 255.255.255.255

[IE-RPIO-LS1-F03]
[1999102108] outputWP() End: 1999-10-21 11:51:00
True, summarization at area boundaries, and
the use of stubby areas with multiple area
border routers, may change the routing with
respect to RIP. What does that suggest? That,
perhaps, summarization and stubby areas
should be added once the basic OSPF is
working? After all, the existing network is
working, to some extent, without them.
Bay does recommend changing the inteface
costs to 108/bandwidth once the conversion is
complete. Summarization and stub areas can
be added after the costs are changed.
Copyright © 1999 Genium Publishing Corporation

×